Back to all reports

The WAIT button appears to be permanently on

Reported via desktop in the Pedestrian wait button not working category anonymously at 15:19, Friday 5 February 2021

Sent to TfL less than a minute later. TfL ref: FMS2527477.

The WAIT button appears to be permanently on, so the lights automatically start to go RED even when there is no one there to have pressed it. This is causing excessive traffic queuing. I sat through 2 sequences and RED - GREEN - RED with no pedestrians anywhere near the crossing.

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • Thank you for your report. This will now be investigated by our team and we will aim to update you on progress within 10 days. If the issue you have reported is an emergency we will aim to update you on progress within 24 hours

    State changed to: In progress

    Posted by TfL at 15:22, Friday 5 February 2021

  • State changed to: Action scheduled

    Updated by TfL at 13:51, Tuesday 9 February 2021

  • The action scheduled for your report should now have been completed as detailed in your previous response. On some occasions it does take a little longer than scheduled. If you have any further queries on this, please either create a new report or contact our Customer Contact Centre on 0343 222 1234

    State changed to: Fixed

    Posted by TfL at 05:32, Wednesday 10 March 2021

Provide an update

Please note that updates are sent to Transport for London. Your information will only be used in accordance with our privacy policy

Next: Tell us about you

or No personal details will be stored, and you will not receive updates about this report.

Your update

Tell us about you

Do you have a Street Care password?