Back to all reports

Sensor not working properly

Reported via desktop in the Stuck on red category anonymously at 10:54, Sunday 16 May 2021

Sent to TfL less than a minute later. TfL ref: FMS2728897.

The lights that show to the cars on Cazenove road seem to be broken. This is a light that's working with a sensor and only goes green if cars are detected. The last month or 2 it seems like the sensor is broken and many times the light will stay red as if no cars are there when meanwhile it starts to pile up many cars and causes a long traffic jam on Cazenove Road. For me living at this corner of Cazenove road this has a very bad effect for 2 reasons, firstly when this happens many cars start hooting and get nervous for waiting so long, and secondly if I'm parked outside my house when this happens there is no way for me to drive out my car from my parking bay as there is a long stretch of cars on the road.

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • Thank you for taking the time to report this to us. It is much appreciated. Your report has been investigated and we can confirm that there is a fault with these traffic lights. We have therefore referred this to our contractors and as it is classed as an emergency it will be fixed or made safe within 24 hours. Should you need anything else or have any questions please contact customer services on 0343 222 1234

    State changed to: Fixed

    Posted by TfL at 11:12, Sunday 16 May 2021

This report is now closed to updates. You can make a new report in the same location.